moveSignedDistanceFromFraction Method
- Implementation of
CurvePrimitive.moveSignedDistanceFromFraction
. (see comments there!) - Find the segment that contains the start fraction
- Move point-by-point from that position to the start or end (respectively for negative or positive signedDistance)
- Optionally extrapolate
moveSignedDistanceFromFraction(startFraction: number, signedDistance: number, allowExtension: undefined, result?: CurveLocationDetail): CurveLocationDetail
Parameter | Type | Description |
---|---|---|
startFraction | number | |
signedDistance | number | |
allowExtension | undefined | |
result | CurveLocationDetail |
Returns - CurveLocationDetail
Defined in
- curve/LineString3d.ts Line 777
Last Updated: 20 June, 2023