globalFractionToSegmentIndexAndLocalFraction Method
Convert a global fraction to a segment index and local fraction.
globalFractionToSegmentIndexAndLocalFraction(globalFraction: number): { fraction: number, index: number }
Parameter | Type | Description |
---|---|---|
globalFraction | number | a fraction f in [0,1] in the linestring parameterization, where the i_th segment (0 <= i < N) is parameterized by i/N <= f <= (i+1)/N. |
Returns - { fraction: number, index: number }
Defined in
- curve/LineString3d.ts Line 590
Last Updated: 20 June, 2023