createForStrokes MethodStatic
- options.needParams triggers creation of fraction array and uvParams array.
- options.needNormals triggers creation of derivatives array
createForStrokes(capacity: number = 0, options: undefined | StrokeOptions): LineString3d
Parameter | Type | Description |
---|---|---|
capacity | number | if positive, initial capacity of arrays |
options | undefined | StrokeOptions | optional, to indicate if fraction and derivative arrays are required. |
Returns - LineString3d
Defined in
- curve/LineString3d.ts Line 1023
Last Updated: 20 June, 2023