appendFractionToPoint Method
Append a suitable evaluation of a curve ..
- always append the curve point
- if fraction array is present, append the fraction
- if derivative array is present, append the derivative BUT ... skip if duplicates the tail of prior points.
appendFractionToPoint(curve: CurvePrimitive, fraction: number): void
Parameter | Type | Description |
---|---|---|
curve | CurvePrimitive | |
fraction | number |
Returns - void
Defined in
- curve/LineString3d.ts Line 988
Last Updated: 20 June, 2023