appendFractionalStrokePoints Method
Evaluate a curve at uniform fractions. Append the evaluations to this linestring.
appendFractionalStrokePoints(curve: CurvePrimitive, numStrokes: number, fraction0: number = 0, fraction1: number = 1, include01: boolean = true): void
Parameter | Type | Description |
---|---|---|
curve | CurvePrimitive | primitive to evaluate. |
numStrokes | number | number of strokes (edges). |
fraction0 | number | starting fraction coordinate |
fraction1 | number | end fraction coordinate |
include01 | boolean | if false, points at fraction0 and fraction1 are omitted. |
Returns - void
Defined in
- curve/LineString3d.ts Line 1047
Last Updated: 20 June, 2023