setFromJSON Method
Construct a line from either of these json forms:
- object with named start and end:
{startPoint: pointValue, endPoint: pointValue}
- array of two point values:
[pointValue, pointValue]
The point values are any values accepted by the Point3d method setFromJSON.
setFromJSON(json?: any): void
Parameter | Type | Description |
---|---|---|
json | any | data to parse. |
Returns - void
Defined in
- curve/LineSegment3d.ts Line 247
Last Updated: 20 June, 2023