constructOffsetXY Method
Construct an offset of the instance curve as viewed in the xy-plane (ignoring z).
constructOffsetXY(offsetDistanceOrOptions: number | OffsetOptions): undefined | CurvePrimitive | CurvePrimitive[]
Parameter | Type | Description |
---|---|---|
offsetDistanceOrOptions | number | OffsetOptions | offset distance (positive to left of the instance curve), or options object |
Returns - undefined | CurvePrimitive | CurvePrimitive[]
Defined in
- curve/LineSegment3d.ts Line 356
Last Updated: 20 June, 2023