createFrom4OutOf5 MethodStatic
Create a transition spiral.
- Inputs must provide exactly 4 of the 5 values
[radius0,radius1,bearing0,bearing1,length
.
createFrom4OutOf5(spiralType: undefined | string, radius0: undefined | number, radius1: undefined | number, bearing0: undefined | Angle, bearing1: undefined | Angle, arcLength: undefined | number, fractionInterval: undefined | Segment1d, localToWorld: Transform): undefined | IntegratedSpiral3d
Parameter | Type | Description |
---|---|---|
spiralType | undefined | string | one of "clothoid", "bloss", "biquadratic", "cosine", "sine". If undefined, "clothoid" is used. |
radius0 | undefined | number | radius (or 0 for tangent to line) at start |
radius1 | undefined | number | radius (or 0 for tangent to line) at end |
bearing0 | undefined | Angle | bearing, measured CCW from x axis at start. |
bearing1 | undefined | Angle | bearing, measured CCW from x axis at end. |
arcLength | undefined | number | |
fractionInterval | undefined | Segment1d | optional fractional interval for an "active" portion of the curve. if omitted, the full [0,1] is used. |
localToWorld | Transform | placement transform |
Returns - undefined | IntegratedSpiral3d
Defined in
- curve/spiral/IntegratedSpiral3d.ts Line 209
Last Updated: 20 June, 2023