GeometryQueryCategory Type alias
Describes the category of a GeometryQuery, enabling type-switching like:
function processGeometryQuery(q: GeometryQuery): void {
if ("solid" === q.geometryCategory)
alert("Solid type = " + q.solidPrimitiveType; // compiler knows q is an instance of SolidPrimitive
// ...etc...
Each string maps to a particular subclass of GeometryQuery:
- "polyface" => Polyface
- "curvePrimitive" => CurvePrimitive
- "curveCollection" => CurveCollection
- "solid" => SolidPrimitive
- "point" => CoordinateXYZ
- "pointCollection" => PointString3d
- "bsurf" => BSpline2dNd (which is an intermediate class shared by BSplineSurface3d and BSplineSurface3dH)
see AnyGeometryQuery
GeometryQueryCategory = "polyface" | "curvePrimitive" | "curveCollection" | "solid" | "point" | "pointCollection" | "bsurf"
Defined in
- curve/GeometryQuery.ts Line 39
Last Updated: 20 June, 2023