dispatchToGeometryHandler MethodAbstract
- "double dispatch" call pattern.
- User code implements a
GeometryHandler
with specialized methods to handleLineSegment3d
,Arc3d
etc as relevant to its use case. - Each such
GeometryQuery
class implements this method as a one-line method containing the appropriate call such ashandler.handleLineSegment3d ()
- This allows each type-specific method to be called without a switch or
instanceof
test.
dispatchToGeometryHandler(handler: GeometryHandler): any
Parameter | Type | Description |
---|---|---|
handler | GeometryHandler | handler to be called by the particular geometry class |
Returns - any
Defined in
- curve/GeometryQuery.ts Line 134
Last Updated: 20 June, 2023