rangeBetweenFractionsByCount Method
Returns an approximate range based on a fixed number of evaluations
- Default implementation returns a range determined by evaluating a specified number of points on the curve.
- Optional evaluate again at interval midpoints and extrapolate any increase
- For a smooth curve, Richardson extrapolation suggests each subdivision moves 3/4 of the way to final. So extrapolationFactor of 1/3 gets speculatively moves closer to the tight range, and larger multipliers increase confidence in being safely larger.
rangeBetweenFractionsByCount(fraction0: number, fraction1: number, count: number, transform?: Transform, extrapolationFactor: number = 0.0): Range3d
Parameter | Type | Description |
---|---|---|
fraction0 | number | start fraction for evaluation |
fraction1 | number | end fraction for evaluation |
count | number | number of points to evaluate |
transform | Transform | |
extrapolationFactor | number | if positive, evaluate again at interval midpoints and apply this fraction multiplier to any increase in size. |
Returns - Range3d
Defined in
- curve/CurvePrimitive.ts Line 267
Last Updated: 20 June, 2023