quickLength MethodAbstract
Compute a length which may be an fast approximation to the true length. This is expected to be either (a) exact or (b) larger than the actual length, but by no more than a small multiple, perhaps up to PI/2, but commonly much closer to 1.
- An example use of this is for setting a tolerance which is a small multiple of the curve length.
- Simple line, circular arc, and transition spiral may return exact length
- Ellipse may return circumference of some circle or polygon that encloses the ellipse.
- bspline curve may return control polygon length
quickLength(): number
Returns - number
Defined in
- curve/CurvePrimitive.ts Line 489
Last Updated: 20 June, 2023