moveSignedDistanceFromFractionGeneric MethodProtected
Generic algorithm to search for point at signed distance from a fractional startPoint.
- This will work for well for smooth curves.
- Curves with tangent or other low-order-derivative discontinuities may need to implement specialized algorithms.
- We need to find an endFraction which is the end-of-interval (usually upper) limit of integration of the tangent magnitude from startFraction to endFraction
- That integral is a function of endFraction.
- The derivative of that integral with respect to end fraction is the tangent magnitude at end fraction.
- Use that function and (easily evaluated!) derivative for a Newton iteration
- TO ALL WHO HAVE FUZZY MEMORIES OF CALCULUS CLASS: "The derivative of the integral wrt upper limit is the value of the integrand there" is the fundamental theorem of integral calculus !!! The fundamental theorem is not just an abstraction !!! It is being used here in its barest possible form !!!
- See https://en.wikipedia.org/wiki/Fundamental_theorem_of_calculus
moveSignedDistanceFromFractionGeneric(startFraction: number, signedDistance: number, allowExtension: boolean, result?: CurveLocationDetail): CurveLocationDetail
Parameter | Type | Description |
---|---|---|
startFraction | number | |
signedDistance | number | |
allowExtension | boolean | |
result | CurveLocationDetail |
Returns - CurveLocationDetail
Defined in
- curve/CurvePrimitive.ts Line 393
Last Updated: 20 June, 2023