fractionToFrenetFrame Method
Construct a frenet frame:
- origin at the point on the curve
- x axis is unit vector along the curve (tangent)
- y axis is perpendicular and in the plane of the osculating circle.
- z axis perpendicular to those.
fractionToFrenetFrame(fraction: number, result?: Transform): undefined | Transform
Parameter | Type | Description |
---|---|---|
fraction | number | |
result | Transform |
Returns - undefined | Transform
Defined in
- curve/CurvePrimitive.ts Line 163
Last Updated: 20 June, 2023