curveLengthBetweenFractions Method
Returns a (high accuracy) length of the curve between fractional positions
- Curve length is always positive.
- Default implementation applies a generic gaussian integration.
- Most curve classes (certainly LineSegment, LineString, Arc) are expected to provide efficient implementations.
curveLengthBetweenFractions(fraction0: number, fraction1: number): number
Parameter | Type | Description |
---|---|---|
fraction0 | number | |
fraction1 | number |
Returns - number
Defined in
- curve/CurvePrimitive.ts Line 220
Last Updated: 20 June, 2023