constructOffsetXY MethodAbstract
Construct an offset of the instance curve as viewed in the xy-plane (ignoring z).
- No attempt is made to join the offsets of smaller constituent primitives. To construct a fully joined offset for an aggregate instance (e.g., LineString3d, CurveChainWithDistanceIndex), use RegionOps.constructCurveXYOffset() instead.
constructOffsetXY(offsetDistanceOrOptions: number | OffsetOptions): undefined | CurvePrimitive | CurvePrimitive[]
Parameter | Type | Description |
---|---|---|
offsetDistanceOrOptions | number | OffsetOptions | offset distance (positive to left of the instance curve), or options object |
Returns - undefined | CurvePrimitive | CurvePrimitive[]
Defined in
- curve/CurvePrimitive.ts Line 743
Last Updated: 20 June, 2023