collectCurvePrimitivesGo Method
Return an array containing only the curve primitives.
- This DEFAULT simply pushes
this
to the collectorArray. - CurvePrimitiveWithDistanceIndex optionally collects its members.
collectCurvePrimitivesGo(collectorArray: CurvePrimitive[], _smallestPossiblePrimitives: boolean, _explodeLinestrings: boolean = false): void
Parameter | Type | Description |
---|---|---|
collectorArray | CurvePrimitive[] | array to receive primitives (pushed -- the array is not cleared) |
_smallestPossiblePrimitives | boolean | |
_explodeLinestrings | boolean |
Returns - void
Defined in
- curve/CurvePrimitive.ts Line 720
Last Updated: 20 June, 2023