collectCurvePrimitives Method
Return an array containing only the curve primitives.
- This DEFAULT captures the default result construction and calls collectCurvePrimitivesGo
collectCurvePrimitives(collectorArray?: CurvePrimitive[], smallestPossiblePrimitives: boolean = false, explodeLinestrings: boolean = false): CurvePrimitive[]
Parameter | Type | Description |
---|---|---|
collectorArray | CurvePrimitive[] | optional array to receive primitives. If present, new primitives are ADDED (without clearing the array.) |
smallestPossiblePrimitives | boolean | if false, CurvePrimitiveWithDistanceIndex returns only itself. If true, it recurses to its (otherwise hidden) children. |
explodeLinestrings | boolean |
Returns - CurvePrimitive[]
Defined in
- curve/CurvePrimitive.ts Line 730
Last Updated: 20 June, 2023