addMappedStrokesToLineString3D Method
- evaluate strokes at fractions indicated in a StrokeCountMap.
- Base class implementation (here) gets the simple count from computeStrokeCountForOptions and strokes at uniform fractions.
- LineString3d, arc3d, BezierCurve3d, BezierCurve3dH accept that default.
- Subdivided primitives (linestring, bspline curve) implement themselves and evaluate within components.
- CurvePrimitiveWithDistanceIndex recurses to its children.
- if packedFraction and packedDerivative arrays are present in the LineString3d, fill them.
addMappedStrokesToLineString3D(map: StrokeCountMap, linestring: LineString3d): number
Parameter | Type | Description |
---|---|---|
map | StrokeCountMap | = stroke count data. |
linestring | LineString3d | = receiver linestring. |
Returns - number
number of strokes added. 0 if any errors matching the map to the curve primitive.
Defined in
- curve/CurvePrimitive.ts Line 691
Last Updated: 20 June, 2023