collectCurvePrimitives Method
Return an array containing only the curve primitives.
collectCurvePrimitives(collectorArray?: CurvePrimitive[], smallestPossiblePrimitives: boolean = false, explodeLineStrings: boolean = false): CurvePrimitive[]
Parameter | Type | Description |
---|---|---|
collectorArray | CurvePrimitive[] | optional array to receive primitives. If present, new primitives are ADDED (without clearing the array.) |
smallestPossiblePrimitives | boolean | if false, CurvePrimitiveWithDistanceIndex returns only itself. If true, it recurses to its (otherwise hidden) children. |
explodeLineStrings | boolean |
Returns - CurvePrimitive[]
Defined in
- curve/CurveCollection.ts Line 122
Last Updated: 20 June, 2023