constructOffsetXY Method
Construct an offset of each child as viewed in the xy-plane (ignoring z).
- No attempt is made to join the offset children. Use RegionOps.constructCurveXYOffset() to return a fully joined offset.
constructOffsetXY(offsetDistanceOrOptions: number | OffsetOptions): undefined | CurvePrimitive | CurvePrimitive[]
Parameter | Type | Description |
---|---|---|
offsetDistanceOrOptions | number | OffsetOptions | offset distance (positive to left of the instance curve), or options object |
Returns - undefined | CurvePrimitive | CurvePrimitive[]
Defined in
- curve/CurveChainWithDistanceIndex.ts Line 729
Last Updated: 20 June, 2023