collectCurvePrimitivesGo Method
Return an array containing only the curve primitives.
- This DEFAULT simply pushes
this
to the collectorArray. - CurvePrimitiveWithDistanceIndex optionally collects its members.
collectCurvePrimitivesGo(collectorArray: CurvePrimitive[], smallestPossiblePrimitives: boolean = false, explodeLineStrings: boolean = false): void
Parameter | Type | Description |
---|---|---|
collectorArray | CurvePrimitive[] | array to receive primitives (pushed -- the array is not cleared) |
smallestPossiblePrimitives | boolean | if false, CurvePrimitiveWithDistanceIndex returns only itself. If true, it recurses to its (otherwise hidden) children. |
explodeLineStrings | boolean |
Returns - void
Defined in
- curve/CurveChainWithDistanceIndex.ts Line 396
Last Updated: 20 June, 2023