cyclicCurvePrimitive Method
Return the [index]
curve primitive, optionally using modulo
to mapindex
to the cyclic indexing.
- In particular,
-1
is the final curve.
cyclicCurvePrimitive(index: number, cyclic: boolean = true): undefined | CurvePrimitive
Parameter | Type | Description |
---|---|---|
index | number | cyclic index |
cyclic | boolean |
Returns - undefined | CurvePrimitive
Defined in
- curve/CurveCollection.ts Line 229
Last Updated: 20 June, 2023