toMatrix3d Method
Expand the angles into a (rigid rotation) matrix.
- The returned matrix is "rigid" (i.e., it has unit length rows and columns, and its transpose is its inverse).
- The rigid matrix is always a right handed coordinate system.
toMatrix3d(result?: Matrix3d): Matrix3d
Parameter | Type | Description |
---|---|---|
result | Matrix3d | optional pre-allocated Matrix3d |
Returns - Matrix3d
Defined in
- geometry3d/YawPitchRollAngles.ts Line 170
Last Updated: 20 June, 2023