createFromMatrix3d MethodStatic
Attempts to create a YawPitchRollAngles object from a Matrix3d
- This conversion fails if the matrix is not rigid (unit rows and columns, and transpose is inverse)
- In the failure case the method's return value is
undefined
. - In the failure case, if the optional result was supplied, that result will nonetheless be filled with a set of angles.
createFromMatrix3d(matrix: Matrix3d, result?: YawPitchRollAngles): undefined | YawPitchRollAngles
Parameter | Type | Description |
---|---|---|
matrix | Matrix3d | |
result | YawPitchRollAngles |
Returns - undefined | YawPitchRollAngles
Defined in
- geometry3d/YawPitchRollAngles.ts Line 269
Last Updated: 20 June, 2023