XYAndZ.almostEqual Function
Return true if two XYAndZs have equal x,y,z parts within a specified tolerance.
almostEqual(a: Readonly<WritableXYAndZ>, b: Readonly<WritableXYAndZ>, tol?: number): boolean
Parameter | Type | Description |
---|---|---|
a | Readonly<WritableXYAndZ> | The first XYAndZ to compare |
b | Readonly<WritableXYAndZ> | The second XYAndZ to compare |
tol | number |
Returns - boolean
true if the difference in each coordinate of a
and b
is smaller than tol
.
Defined in
- geometry3d/XYZProps.ts Line 79
Last Updated: 20 June, 2023