tryNormalizeInPlace Method
Try to normalize (divide by magnitude), storing the result in place.
tryNormalizeInPlace(smallestMagnitude: number = Geometry.smallMetricDistance): boolean
Parameter | Type | Description |
---|---|---|
smallestMagnitude | number | smallest magnitude allowed as divisor. |
Returns - boolean
false if magnitude is too small. In this case the vector is unchanged.
Defined in
- geometry3d/Point3dVector3d.ts Line 1215
Last Updated: 20 June, 2023