rotateXY Method
Rotate the xy parts of this vector around the z axis.
- z is taken unchanged to the result.
rotateXY(angle: Angle, result?: Vector3d): Vector3d
Parameter | Type | Description |
---|---|---|
angle | Angle | angle to rotate |
result | Vector3d | optional preallocated result |
Returns - Vector3d
Defined in
- geometry3d/Point3dVector3d.ts Line 1015
Last Updated: 20 June, 2023