isPerpendicularTo Method
Test if this vector is perpendicular to other.
- The input tolerances in
options
, if given, are considered to be squared for efficiency's sake, so if you have a distance or angle tolerance t, you should pass in t * t.
isPerpendicularTo(other: Vector2d, returnValueIfAnInputIsZeroLength: boolean = false, options?: PerpParallelOptions): boolean
Parameter | Type | Description |
---|---|---|
other | Vector2d | second vector in comparison. |
returnValueIfAnInputIsZeroLength | boolean | if either vector is near zero length, return this value. |
options | PerpParallelOptions | optional radian and distance tolerances. |
Returns - boolean
Defined in
- geometry3d/Point2dVector2d.ts Line 653
Last Updated: 20 June, 2023