isParallelTo Method
Test if this vector is parallel to other.
- The input tolerances in
options
, if given, are considered to be squared for efficiency's sake, so if you have a distance or angle tolerance t, you should pass in t * t.
isParallelTo(other: Vector2d, oppositeIsParallel: boolean = false, returnValueIfAnInputIsZeroLength: boolean = false, options?: PerpParallelOptions): boolean
Parameter | Type | Description |
---|---|---|
other | Vector2d | second vector for comparison. |
oppositeIsParallel | boolean | whether to consider diametrically opposed vectors as parallel. |
returnValueIfAnInputIsZeroLength | boolean | |
options | PerpParallelOptions | optional radian and distance tolerances. |
Returns - boolean
Defined in
- geometry3d/Point2dVector2d.ts Line 628
Last Updated: 20 June, 2023