createOffsetBisector MethodStatic
Return a vector that bisects the angle between two normals and extends to the intersection of two offset lines
- returns
undefined
ifunitPerpA = -unitPerpB
(i.e., are opposite) - math details can be found at docs/learning/geometry/PointVector.md
createOffsetBisector(unitPerpA: Vector2d, unitPerpB: Vector2d, offset: number): undefined | Vector2d
Parameter | Type | Description |
---|---|---|
unitPerpA | Vector2d | unit perpendicular to incoming direction |
unitPerpB | Vector2d | unit perpendicular to outgoing direction |
offset | number | offset distance |
Returns - undefined | Vector2d
Defined in
- geometry3d/Point2dVector2d.ts Line 425
Last Updated: 20 June, 2023