appendPolygonClip Method
Optional polygon clip method.
- This is expected to be implemented by planar clip structures.
- This is unimplemented for curve clippers (e.g. sphere) for which polygon clip result has curved edges.
appendPolygonClip(xyz: GrowableXYZArray, insideFragments: GrowableXYZArray[], outsideFragments: GrowableXYZArray[], arrayCache: ): void
Parameter | Type | Description |
---|---|---|
xyz | GrowableXYZArray | input polygon. This is not changed. |
insideFragments | GrowableXYZArray[] | Array to receive "inside" fragments. Each fragment is a GrowableXYZArray grabbed from the cache. This is NOT cleared. |
outsideFragments | GrowableXYZArray[] | Array to receive "outside" fragments. Each fragment is a GrowableXYZArray grabbed from the cache. This is NOT cleared. |
arrayCache | cache for reusable GrowableXYZArray. |
Returns - void
Defined in
Last Updated: 20 June, 2023