reverseIfNeededForDeltaSign Method
- if
x1-x0
multiplied by the scale factor is (strictly) negative, swap the x0 and x1 member values. - This makes the fractionToPoint evaluates reverse direction.
reverseIfNeededForDeltaSign(sign: number = 1): void
Parameter | Type | Description |
---|---|---|
sign | number |
Returns - void
Defined in
- geometry3d/Segment1d.ts Line 98
Last Updated: 20 June, 2023