clampDirectedTo01 Method
- On input, (f0,f1) is a (directed) segment.
- On output, it is restricted to (0,1) while maintaining direction
- If the clip leaves nothing, leave this segment alone and return false.
- If the clip leaves something, update this segment and return true.
clampDirectedTo01(): boolean
Returns - boolean
Defined in
- geometry3d/Segment1d.ts Line 152
Last Updated: 20 June, 2023