tryNormalizeInPlaceWithAreaWeight Method
- If parameter
a
is clearly nonzero and the direction vector can be normalized,- save the parameter
a
as the optionala
member of the ray. - normalize the ray's direction vector
- save the parameter
- If parameter
a
is nearly zero,- Set the
a
member to zero - Set the ray's direction vector to zero.
- Set the
tryNormalizeInPlaceWithAreaWeight(a: number): boolean
Parameter | Type | Description |
---|---|---|
a | number | area to be saved. |
Returns - boolean
Defined in
- geometry3d/Ray3d.ts Line 226
Last Updated: 20 June, 2023