perpendicularPartOfVectorToTarget Method
Construct a vector from ray.origin
to target point.
- return the part of the vector that is perpendicular to
ray.direction
. - i.e. return the shortest vector from the ray to the point.
perpendicularPartOfVectorToTarget(targetPoint: Readonly<WritableXYAndZ>, result?: Vector3d): Vector3d
Parameter | Type | Description |
---|---|---|
targetPoint | Readonly<WritableXYAndZ> | |
result | Vector3d |
Returns - Vector3d
Defined in
- geometry3d/Ray3d.ts Line 299
Last Updated: 20 June, 2023