getPoint2dAtCheckedPointIndex Method

Access by index, returning strongly typed Point2d

  • This returns the xy value but NOT reference to the point in the "carried" array.

getPoint2dAtCheckedPointIndex(index: number, result?: Point2d): undefined | Point2d

Parameter Type Description
index number index of point within the array
result Point2d caller-allocated destination

Returns - undefined | Point2d

undefined if the index is out of bounds

Defined in

Last Updated: 20 June, 2023