addForwardLeft Method
Starting at this point, move along vector by tangentFraction of the vector length, and then to the left by leftFraction of the perpendicular vector length.
addForwardLeft(tangentFraction: number, leftFraction: number, vector: Vector2d): Point2d
Parameter | Type | Description |
---|---|---|
tangentFraction | number | distance to move along the vector, as a fraction of vector |
leftFraction | number | distance to move perpendicular to the vector, as a fraction of the rotated vector |
vector | Vector2d | the other vector |
Returns - Point2d
Defined in
- geometry3d/Point2dVector2d.ts Line 225
Last Updated: 20 June, 2023