createFromTransformColumnsXYAndLengths MethodStatic
Return a Plane3dByOriginAndVectors, with
- origin is the translation (aka origin) from the Transform
- vectorU is the X column of the transform
- vectorV is the Y column of the transform.
createFromTransformColumnsXYAndLengths(transform: Transform, xLength: undefined | number, yLength: undefined | number, result?: Plane3dByOriginAndVectors): Plane3dByOriginAndVectors
Parameter | Type | Description |
---|---|---|
transform | Transform | source transform |
xLength | undefined | number | optional length to impose on vectorU. |
yLength | undefined | number | optional length to impose on vectorV. |
result | Plane3dByOriginAndVectors | optional preexisting result |
Returns - Plane3dByOriginAndVectors
Defined in
Last Updated: 20 June, 2023