createOriginAndTargetXY MethodStatic
create a new Plane3dByOriginAndUnitNormal with unit normal (a) in the xy plane (b) perpendicular to the line defined by xy parts of origin to target.
- origin and normal both have z = 0.
- The inputs are NOT captured.
- Returns undefined if the normal vector is all zeros.
createOriginAndTargetXY(origin: Readonly<WritableXAndY>, target: Readonly<WritableXAndY>, result?: Plane3dByOriginAndUnitNormal): undefined | Plane3dByOriginAndUnitNormal
Parameter | Type | Description |
---|---|---|
origin | Readonly<WritableXAndY> | |
target | Readonly<WritableXAndY> | |
result | Plane3dByOriginAndUnitNormal |
Returns - undefined | Plane3dByOriginAndUnitNormal
Defined in
Last Updated: 20 June, 2023