xyzPlusMatrixTimesCoordinatesToFloat64Array MethodStatic
Treat the 3x3 matrix and origin as upper 3x4 part of a 4x4 matrix, with 0001 as the final row.
Multiply times point with coordinates [x,y,z,w]
xyzPlusMatrixTimesCoordinatesToFloat64Array(origin: XYZ, matrix: Matrix3d, x: number, y: number, z: number, result?: Float64Array): Float64Array
Parameter | Type | Description |
---|---|---|
origin | XYZ | translation part (xyz in column 3) |
matrix | Matrix3d | matrix part (leading 3x3) |
x | number | x part of multiplied point |
y | number | y part of multiplied point |
z | number | z part of multiplied point |
result | Float64Array | optional result. |
Returns - Float64Array
Defined in
- geometry3d/Matrix3d.ts Line 1679
Last Updated: 20 June, 2023