toQuaternion Method
convert the matrix to a quaternion.
toQuaternion(): Point4d
note This calculation requires the matrix to have unit length rows and columns. WARNING: There is frequent confusion over whether a "from quaternion" matrix is organized by rows and columns. WARNING: If you find that the matrix seems to rotate by the opposite angle expect it, transpose it.
Returns - Point4d
Defined in
- geometry3d/Matrix3d.ts Line 2573
Last Updated: 20 June, 2023