setFromJSON Method
Copy data from various input forms to this matrix. The source can be:
- Another
Matrix3d
- An array of 3 arrays, each of which has the 3 numbers for a row of the matrix.
- An array of 4 or 9 numbers in row major order.
- WARNING: if json is an array of numbers but size is not 4 or 9, the matrix is set to zeros.
setFromJSON(json?: Matrix3d | Matrix3dProps): void
Parameter | Type | Description |
---|---|---|
json | Matrix3d | Matrix3dProps |
Returns - void
Defined in
- geometry3d/Matrix3d.ts Line 264
Last Updated: 20 June, 2023