scaleRows Method
create a Matrix3d whose rows are scaled copies of this Matrix3d.
scaleRows(scaleX: number, scaleY: number, scaleZ: number, result?: Matrix3d): Matrix3d
Parameter | Type | Description |
---|---|---|
scaleX | number | scale factor for row x |
scaleY | number | scale factor for row y |
scaleZ | number | scale factor for row z |
result | Matrix3d | optional result. |
Returns - Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 2300
Last Updated: 20 June, 2023