normalizeColumnsInPlace Method
Normalize each column in place.
- For false return the magnitudes are stored in the originalMagnitudes vector but no columns are altered.
normalizeColumnsInPlace(originalMagnitudes?: Vector3d): boolean
Parameter | Type | Description |
---|---|---|
originalMagnitudes | Vector3d | optional vector to receive original column magnitudes. |
Returns - boolean
Return true if all columns had nonzero lengths.
Defined in
- geometry3d/Matrix3d.ts Line 2122
Last Updated: 20 June, 2023