makeRigid Method
Adjust the matrix in place so that:
- columns are perpendicular and have unit length
- transpose equals inverse
- mirroring is removed
makeRigid(axisOrder: AxisOrder = AxisOrder.XYZ): boolean
Parameter | Type | Description |
---|---|---|
axisOrder | AxisOrder | how to reorder the matrix columns |
Returns - boolean
whether the instance is rigid on return
Defined in
- geometry3d/Matrix3d.ts Line 2512
Last Updated: 20 June, 2023