isRigid Method
Test if the matrix is a pure rotation.
isRigid(allowMirror: boolean = false): boolean
Parameter | Type | Description |
---|---|---|
allowMirror | boolean | whether to widen the test to return true if the matrix is orthogonal (a pure rotation or a mirror) |
Returns - boolean
Defined in
- geometry3d/Matrix3d.ts Line 2458
Last Updated: 20 June, 2023