isAlmostEqualAllowZRotation Method
Test if this
and other
have almost equal Z column and have X and Y columns differing only by a
rotation of the same angle around that Z.
- WARNING: X and Y columns have to be perpendicular to Z column in both
this
andother
.
isAlmostEqualAllowZRotation(other: Matrix3d, tol?: number): boolean
Parameter | Type | Description |
---|---|---|
other | Matrix3d | |
tol | number | optional tolerance for comparisons by Geometry.isDistanceWithinTol |
Returns - boolean
Defined in
- geometry3d/Matrix3d.ts Line 347
Last Updated: 20 June, 2023