factorRigidWithSignedScale Method
Test if all rows and columns are perpendicular to each other and have equal length. If so, the length (or its negative) is the scale factor from a set of rigid axes to these axes.
- result.rigidAxes is the rigid axes (with the scale factor removed)
- result.scale is the scale factor
factorRigidWithSignedScale(): undefined | { rigidAxes: Matrix3d, scale: number }
Returns - undefined | { rigidAxes: Matrix3d, scale: number }
Defined in
- geometry3d/Matrix3d.ts Line 2466
Last Updated: 20 June, 2023