createStandardWorldToView MethodStatic
Create a rotation matrix for one of the 8 standard views.
- Default is TOP view (
local X = world X
,local Y = world Y
,local Z = world Z
). - To change view from the TOP to one of the other 7 standard views, we need to multiply "world data" to
the corresponding matrix1 provided by
createStandardWorldToView(index, false)
and thenmatrix1.multiply(world data)
will returns "local data". - To change view back to the TOP, we need to multiply "local data" to the corresponding matrix2 provided
by
createStandardWorldToView(index, true)
and thenmatrix2.multiply(local data)
will returns "world data".
createStandardWorldToView(index: StandardViewIndex, invert: boolean = false, result?: Matrix3d): Matrix3d
Parameter | Type | Description |
---|---|---|
index | StandardViewIndex | standard view index StandardViewIndex.Top, Bottom, Left, Right, Front, Back, Iso, RightIso |
invert | boolean | if false (default), the return matrix is world to local (view) and if true, the the return matrix is local (view) to world. |
result | Matrix3d | optional result. |
Returns - Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 870
Last Updated: 20 June, 2023